導航:首頁 > 期指持倉 > 股票ema指標的公式源碼

股票ema指標的公式源碼

發布時間:2022-09-28 18:20:53

1. 秒殺一切妖股指標公式源碼是什麼

如下:

{百底公式1}

{AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);

BA:=EMA(AB,5);

頂1:=REFDATE(REF(HHV(H,100),5),DATE);

底1:=REFDATE(REF(LLV(L,100),5),DATE);

中1:=((頂1)+(底1))/2;

頂:IF(AB>0 AND AB-BA<=0,頂1,頂1),COLOR00FF00;

中:IF(AB>0 AND AB-BA<=0,中1,中1),COLORWHITE;

底:IF(AB>0 AND AB-BA<=0,底1,底1),COLORYELLOW;

DRAWTEXT(ISLASTBAR,(頂),STRCAT('',CON2STR(頂,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(中),STRCAT('',CON2STR(中,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(底),STRCAT('',CON2STR(底,2))),COLORWHITE;

{百底公式2}

N:100 NODRAW ;

高:IF(CURRBARSCOUNT<=N,CONST(HHV(H,N)),DRAWNULL),COLORGREEN ;

低:IF(CURRBARSCOUNT<=N,CONST(LLV(L,N)),DRAWNULL),COLORYELLOW;

NOTEXT中:低+(高-低)/2 COLORWHITE;

{漲幅:(C-低)/低*100 NODRAW COLORFF00FF;}

漲幅:((C-低)/(高-低))*100 NODRAW COLORFF00FF;

漲天數:LLVBARS(L,100)COLORWHITE NODRAW;

{跌幅:((C-高)/高)*100 NODRAW COLORD9D919;};

跌幅:((C-高)/(高-低))*100 NODRAW COLORD9D919;

跌天數:HHVBARS(H,100)COLORWHITE NODRAW;

DRAWTEXT(ISLASTBAR,(高-(高-低)/50),STRCAT('',CON2STR(高-(高-低)/50,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(NOTEXT中),STRCAT('',CON2STR(NOTEXT中,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(低),STRCAT('',CON2STR(低,2))),COLORWHITE;

MA5:MA(C,5),COLORYELLOW;

NOTEXT5:IF((C<=MA5 OR MA5<=REF(MA5,1)),MA5,DRAWNULL),COLORFFFF00;

振幅:((高-低)/低)*100 NODRAW COLORGREEN;

均周月:INBLOCK('均周')AND INBLOCK('均月') COLORWHITE NODRAW;

逃周月:INBLOCK('逃周')AND INBLOCK('逃月')NODRAW COLORYELLOW;

{VAR6:=REF(C,1);

VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;

DRAWTEXT(CROSS(82,VAR7),H*1.01,'高拋'),COLORFFFFFF;

VAR1:=LLV(LOW,21);

VAR2:=HHV(HIGH,21);

AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

AB:=CROSS(AK1,AK);

DRAWTEXT((AB = 1),(LOW * 0.99),'低吸'),COLORYELLOW;};

{百底距:=((C-低)/低)*100;

XG1:=BETWEEN(C,低,低*(1+0.03));

盤整天:BARSLASTCOUNT(XG1)NODRAW COLORYELLOW;}

{上漲值:=MA((H+REF(L,1))/2,3);

買進高點:=MA((H+REF(H,1))/2,3);

VAR1:=((O+H+L+2*C)/5)*2-L;

突破買入值:=MA(VAR1,3);{LSS軸點突破買入值}

{下跌值:=MA((REF(H,1)+L)/2,3);

賣出低點:=MA((REF(L,1)+L)/2,3);

VAR2:=((O+H+L+2*C)/5)*2-H;

突破賣出值:=MA(VAR2,3);

次日賣出點:=(上漲值+買進高點+突破買入值+H)/4;

次日買入點:=(下跌值+賣出低點+突破賣出值+L)/4;

均價:=(2*C+L+H/4);

買入價:IF(均價/REF(均價,1)>1,次日買入點*1.01,次日買入點)COLORWHITE NODRAW;

次低價:IF(均價/REF(均價,1)>1,次日買入點/1.0382,次日買入點)NODRAW COLORYELLOW;

賣出價:IF(均價/REF(均價,1)>1,次日賣出點*1.0191,次日賣出點)NODRAW;

必賣價:IF(均價/REF(均價,1)>1,次日賣出點*1.05,次日賣出點)COLORD9D919 NODRAW;}

{AC:=REF(C,1);

漲停K線:=IF((C-AC)*100/AC>=(10-0.01*100/AC),1,0);

跌停K線:=IF((AC-C)*100/AC>=(10-0.01*100/AC),1,0);

STICKLINE(漲停K線,OPEN,CLOSE,2.5,0),COLORYELLOW;

STICKLINE(跌停K線,OPEN,CLOSE,2.5,0),COLORED9564;}

{漲停顏色粉色,完美區分20%10%5%,創業板20200823前10%照樣變色}

BK:=IF(INBLOCK('科創板'),0.2,IF(INBLOCK('創業板'),0.2,IF(INBLOCK('ST板塊'),0.05,0.1)));

XA_1:=IF(DATE<=1200823,1,0);

STICKLINE((C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1,O,C,3,0),COLORYELLOW;

STICKLINE((C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1,O,C,3,0),COLORED9564;

STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,3,0),COLORYELLOW;

STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,3,0),COLORED9564;

{STICKLINE((H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1),H,MAX(C,O),0.1,0),COLORYELLOW;{漲停後回落}

{STICKLINE((L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1),L,MIN(C,O),0.1,0),COLORED9564;{跌停後回升}

{Z1:=STRCAT(HYBLOCK,' ');

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,' ');

DRAWTEXT_FIX(ISLASTBAR,0,10,0,STRCAT(Z3,GNBLOCK)),COLORWHITE;}

{DRAWTEXT_FIX(1,0.00,0.00,0,'主題投資:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.00,0,EXTERNSTR(0,1))COLORYELLOW;

DRAWTEXT_FIX(1,0.00,0.06,0,'主營業務:')COLORWHITE;

DRAWTEXT_FIX(1,0.06,0.06,0,EXTERNSTR(0,2))COLORWHITE;

DRAWTEXT_FIX(1,0.00,0.12,0,'公司亮點:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.12,0,EXTERNSTR(0,3))COLORYELLOW; }

{流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;}

{漲停統計}

{漲停:=CLOSE/REF(CLOSE,1)>=1.095;

ZTCS:=COUNT(漲停,BARSSINCE(漲停)+1);}

{DRAWNUMBER(漲停,HIGH*1.04,ZTCS),COLORYELLOW;}

{GZT1:=STRCAT('共漲停: ',CON2STR(ZTCS,0));

GZT2:=STRCAT(GZT1,'次');

SSTS1:=STRCAT('上市: ',CON2STR(FINANCE(42),0));

SSTS2:=STRCAT(SSTS1,'天');

NTZZT1:=STRCAT('距今:',CON2STR(CONST(BARSLAST(漲停)),0));

NTZZT2:=STRCAT(NTZZT1,'天有漲停');

ZTTJ1:=STRCAT(SSTS2,GZT2);

ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);

ZTTJ:=STRCAT('漲停統計:',ZTTJ2);

DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.18,0,ZTTJ),COLORWHITE;}。

2. 比較好的買賣點提示的股票指標公式

做長線的花··參考macd·
加上月線
周線參考··做中線的花
參考kdj指標
在參考周線日線··
短線的花
建議去參考
cci指標
當股價上攻一百就是買點··跌破一百就是賣點··
不懂的可以跟我交流
465208371
我的扣扣

閱讀全文

與股票ema指標的公式源碼相關的資料

熱點內容
博創科技股票股 瀏覽:532
中國西電股票歷史分紅 瀏覽:829
蘇州胥口有沒有南京銀行股票 瀏覽:805
可長期持有的股票分紅高嗎 瀏覽:482
看股票大盤APP 瀏覽:367
目前最易投資的中長線股票 瀏覽:201
股票重組後股價變化 瀏覽:604
創業板的股票退市會提醒你么 瀏覽:358
股票重組復牌價格 瀏覽:242
阿爾法歐洲etf股票代碼 瀏覽:620
股票中國天然 瀏覽:820
股票和債券最近 瀏覽:124
多贏股票軟體 瀏覽:915
國信證券股票002736 瀏覽:141
中國海誠的股票代碼 瀏覽:967
有福科技股票代碼 瀏覽:719
上市公司被接管後股票會退市么 瀏覽:397
中國石油的股票為何那麼低 瀏覽:953
漢鍾精機股票走勢圖 瀏覽:196
中國消費股票龍頭股 瀏覽:902