導航:首頁 > 期指持倉 > 股票指標編寫指標下破

股票指標編寫指標下破

發布時間:2022-10-04 04:19:01

A. 麻煩會股票指標公式的幫忙寫兩個指標選股公式,跪謝!

第一個公式:要求UPPER,LOWER,ENE指標線均向上,收盤價下破LOWER線
N:=25;M1:=6;M2:=6;
UPPER:=(1+M1/100)*MA(CLOSE,N);
LOWER:=(1-M2/100)*MA(CLOSE,N);
ENE:=(UPPER+LOWER)/2;
X1:=UPPER>=REF(UPPER,1) AND LOWER>=REF(LOWER,1) AND ENE>=REF(ENE,1);
破下軌:C<LOWER AND X1;

第二個公式:要求UPPER,LOWER,ENE指標線均向上,收盤價大於ENE線
N:=25;M1:=6;M2:=6;
UPPER:=(1+M1/100)*MA(CLOSE,N);
LOWER:=(1-M2/100)*MA(CLOSE,N);
ENE:=(UPPER+LOWER)/2;
X2:=UPPER>=REF(UPPER,1) AND LOWER>=REF(LOWER,1) AND ENE>=REF(ENE,1);
大於:C>ENE AND X2;

希望能夠幫助您,順祝馬年投資順利!

B. 怎樣編寫炒股指標

操盤線指標公式
bu:=cross(high,SAR(3,1,20));
sel:=cross(SAR(3,1,20),low);
var1:=last(high<SAR(3,1,20));
var2:=last(low>sar(3,1,20));
drawtext(bu,high,'買入');
drawtext(sel,low,'賣出');
drawtext(bu,LOW,'B'),valign0,align1,coloryellow,linethick2; drawtext(sel,HIGH,'S'),valign2,align1,colorgreen,linethick2;
STICKLINE(low>SAR(3,1,20) and isdown,high,open,0.5,1),colorred;
STICKLINE(low>SAR(3,1,20) and isdown,close,open,7.5,1),colorred;
STICKLINE(low>SAR(3,1,20) and isdown,close,low,0.5,1),colorred;
STICKLINE(high<SAR(3,1,20) and isup,high,close,0.5,1),colorcyan;
STICKLINE(high<SAR(3,1,20) and isup,close,open,7.5,1),colorcyan;
STICKLINE(high<SAR(3,1,20) and isup,open,low,0.5,1),colorcyan;
drawflagtext(high<SAR(3,1,20) and high>=ref(high,1),high,'明日突破'+forcast(sar(3,1,20),max(var1,2))+'建議關注');
drawflagtext(high<SAR(3,1,20) and high<ref(high,1),high,'持幣觀望'); drawflagtext(low>SAR(3,1,20) and low<=ref(low,1),low,'明日跌破'+forcast(sar(3,1,20),max(var2,2))+'注意止盈');
drawflagtext(low>SAR(3,1,20) and low>ref(low,1),low,'繼續持股');

想要看懂一個公式,最先看的應該是公式的輸出內容,換句話說,操盤線在K線圖上顯示出B點S點,那我們就分析,BS點怎麼得來的。先介紹個常用的輸出函數drawtext,drawtext的格式:drawtext(條件,想要顯示的位置,想要顯示的文字),舉個例子,想要在K線圖上顯示出每個漲停版,可以在均線公式里添加這么句:drawtext((c-ref(c,1))/ref(c,1)>0.095,l,'漲停');這樣就會在漲停那些天k線圖的最低價處顯示漲停兩個字。
我們到以上原碼中找出有drawtext的語句: drawtext(bu,LOW,'B'),valign0,align1,coloryellow,linethick2; drawtext(sel,HIGH,'S'),valign2,align1,colorgreen,linethick2;
套用剛才說的格式,bu就是條件,low(最低價)是想要顯示的位置,想要顯示的文字「B」,(後面這些valign0,align1,coloryellow,linethick2都是顯示的格式,比如字體顏色,字體顯示位置矯正,字體大小),就是說滿足了「bu」這個條件後,就在那天的最低價顯示個B。那麼現在的問題就是什麼是bu條件了,看似很長一段公式,其實最主要就是前兩行: bu:=cross(high,SAR(3,1,20)); sel:=cross(SAR(3,1,20),low);
看到兩行公式,我先解釋下一些基本公式知識,這里bu(buy買),sel(sell賣)是自己定的變數,:後面內容表示bu,sel表示的條件,=表示不需要顯示出來(因為最後通過drawtext顯示),cross的用法是cross(a,b),意思是a上穿b,比如股價上穿30日均線就是cross(close,ma(close,30))。那麼我們再回過來看看什麼是bu?high(最高價)上穿sar(3,1,20),就是說最高價只要上穿sar(3,1,20)就會提示B點,SAR又叫拋物線或停損轉向操作點指標,這個函數會等下重點詳細介紹,先把公式其他部分看完。
後面有六排stickline是畫K線圖用的,大家有沒發現操盤線的蠟燭線和普通k線圖不一樣?介紹下stickline這個函數,用法是stickline(條件,位置1,位置2,寬度,是否實心畫線),我們以最常見的普通K線圖 為例,就是用這個函數畫出來的。
比如說陰線的表達方式就是 STICKLINE(c<o,c,o,10,0),colorcyan;{收盤價如果小於開盤價,在開盤價和收盤價之間畫寬度10的柱子,實心,顏色青色(colorcyan),這里畫出的是陰線中間部分} STICKLINE(c<o,h,l,1,0),colorcyan;{收盤價如果小於開盤價,在最高價和最低價之間畫寬度1的細線,實心,顏色青色(colorcyan),這里畫出的是陰線上下影線部分,如果是畫陽線,這里就要分兩次寫了,因為陽線是空心的,直接最高最低連起來不好看} 介紹完STICKLINE用法,由於時間有限,操盤線的k線畫法就不一一詳述了,一句句看很好理解的。 最下面有4行drawflagtext,和drawtext的區別就是需要十子游標調用並指上去才顯示,格式一樣的:drawflagtext(條件,想要顯示的位置,想要顯示的文字),操盤線十字游標調出後放到每個蠟燭線上有文字提示,就是這個函數做出來的。這里調用了第3,4行的兩個變數var1,var2,通過4種不同情況分別有4種提示。 公式解釋完了,現在來重點講下操盤線中的精髓sar函數以及操盤線的應用,sar全稱叫「Stop and Reveres,縮寫SAR」,是由美國技術分析大師威爾斯·威爾德(Wells Wilder)所創造的,是一種簡單易學、比較准確的中短期技術分析工具。先說下SAR指標的原理,我們從SAR指標英文全稱知道它有兩層含義。一是「stop」,即停損、止損之意,這就要求投資者在買賣某個股票之前,先要設定一個止損價位,以減少投資風險。而這個 止損價位也不是一直不變的,它是隨著股價的波動止損位也要不斷的隨之調整。如何既可以有效地控制住潛在的風險,又不會錯失賺取更大收益的機會,是每個投資 者所追求的目標。但是股市情況變幻莫測,而且不同的股票不同時期的走勢又各不相同,如果止損位設的過高,就可能出現股票在其調整回落時賣出,而賣出的股票 卻從此展開一輪新的升勢,錯失了賺取更大利潤的機會,反之,止損位定的過低,就根本起不到控制風險的作用。因此,如何准確地設定止損位是各種技術分析理論 和指標所闡述的目的,而SAR指標在這方面有其獨到的功能。

C. 關於股票指標編寫的問題

不同的軟體指標編寫函數不同,大智慧指標的psr:
psr:c*FINANCE(1)/FINANCE(20);

由於公司研發預算不是常用的財務指標,不能實現prr

D. 如何編寫股票指標

這要看你想學到什麼程度了,如果僅僅是數學上的公式怎麼計算這種開始比較容易的,只要有些數學基礎就可以了,要是想把指標寫成程序並且在要根據自己的需要設計出指標這個就比較有難度了估計沒有編程基礎很難學會.

E. 如何編寫股票技術指標

不同的股票軟體編寫方法不太一樣~要具體分析。當然不管哪種我都不精通,可能幫不到你。

但是說句打擊你的話。你真的認為指標可以指引方向么?現在的指標比較有突出的成功率的都是建立在資料來源的優勢上,比如原先的贏富,是建立在別人沒有的買賣記錄上,level2是建立在詳細的買賣資料上,並不是因為他們的編寫的邏輯性有多高,分析能力有多強。你真的覺得指標可以指引股票交易么?我很懷疑。就最近的醫葯股漲停,根本就是豬流感引起的爆炒~指標不能指引吧?昨天銀行股的大漲,是因為消息的刺激。估計指標也沒有啥指引性。
如果用現在大家一般能得到的資料來分析。指標可以指引也就是量價而已。這種指標很多。而且基本能用的都用了,基本快速反應失誤率高。反應慢的容易錯過最佳買入時機。而且最重要的是,在盤整的時候都容易失去作用~。
我總認為憑技術指標炒股是最低層次,要不你有錢坐莊,要不你有快人一步的內部消息,要不你對經濟把握比較准確。憑指標判斷~總是不好,至少我認識的很少憑指標賺錢的~ 仁者見仁智者見智。有時間希望多交流。

F. 如何編寫自己的股票指標

上網搜,找你要的大智慧或同花順或其他的,按編寫教程試著編一個看看。

G. 股票中的上穿上破下穿下破是什麼意思

是指K線形態,穿越某條均線。

K線的收盤價在均線的上方或是下方,收盤價收在均線上方為向上突破;收盤價收在均線下方為向下突破 短期走勢分有效突破和無效突破,即連續收在均線上方3天、漲幅為3%,為有效突破,反之,為無效突破。

(7)股票指標編寫指標下破擴展閱讀:

注意事項:

穿頭破腳形成於上漲的過程中,表明趨勢反轉。從主力行為來看,跳空高開是主力打開的出貨空間。若當日陰線對應的成交量急劇放大,股民朋友要更加謹慎,可快速出貨離場。與其他的K線相比,穿頭破腳的見頂信號要更加准確。

股價在行進的途中,恰巧遭到平均線壓力、前波密集的套牢區、大自然數字的壓力區等狀況。注意假陰線是出現於多頭趨勢中,而假陽線則出現於空頭趨勢中。

閱讀全文

與股票指標編寫指標下破相關的資料

熱點內容
博創科技股票股 瀏覽:532
中國西電股票歷史分紅 瀏覽:829
蘇州胥口有沒有南京銀行股票 瀏覽:805
可長期持有的股票分紅高嗎 瀏覽:482
看股票大盤APP 瀏覽:368
目前最易投資的中長線股票 瀏覽:201
股票重組後股價變化 瀏覽:604
創業板的股票退市會提醒你么 瀏覽:358
股票重組復牌價格 瀏覽:242
阿爾法歐洲etf股票代碼 瀏覽:621
股票中國天然 瀏覽:820
股票和債券最近 瀏覽:124
多贏股票軟體 瀏覽:915
國信證券股票002736 瀏覽:141
中國海誠的股票代碼 瀏覽:967
有福科技股票代碼 瀏覽:719
上市公司被接管後股票會退市么 瀏覽:397
中國石油的股票為何那麼低 瀏覽:953
漢鍾精機股票走勢圖 瀏覽:196
中國消費股票龍頭股 瀏覽:902