導航:首頁 > 期指持倉 > vb編寫股票指標

vb編寫股票指標

發布時間:2023-01-25 13:12:51

⑴ 我想老師幫我做一個選股指標下方是我的指標公式就要那個「有錢不賺是傻蛋」那個我在截圖中也有標記

手機端改的代碼超過字數限制,我把代碼給你發追問里,回答里是代碼的截圖。

⑵ 請老師將下列指標上做個標志並以此做個選股指標。謝謝。

v1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5); V4:=2*(V2-V3)*5.5;
主力撤: IF(V4<=0,V4,0),COLORGREEN;
主力進: IF(V4>=0,V4,0);
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
大盤資金進場:
IF(VB>=0,VB,0),COLORYELLOW;
大盤資金撤走:
IF(VB<=0,VB,0),COLORRED;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趨勢線: EMA(V11,3);
V12:=(趨勢線-REF(趨勢線,1))/REF(趨勢線,1)*100;
准備現金: STICKLINE(趨勢線<=13,0,20,5,0),COLORCC9900;
AA:=(趨勢線<=13) AND FILTER((趨勢線<=13),15);
DRAWTEXT (AA,30,'准備現金'),COLORCC9900;
買入股票: STICKLINE(趨勢線<=13 AND V12>13,0,50,5,0),COLOR0099FF;
BB:= (趨勢線<=13 AND V12>13) AND FILTER((趨勢線<=13 AND V12>13),10) ;
DRAWTEXT (BB,60,'買入股票'),COLOR0099FF;
見頂清倉: STICKLINE(趨勢線>=90 AND V12,0,30,5,0),COLORRED;
CC:=(趨勢線>=90 AND V12) AND FILTER((趨勢線>=90 AND V12),10);
同時出現:=主力進>0 AND 大盤資金進場>0 AND 主力撒=0 AND 大盤資金撒走=0 ;
標計:DRAWTEXT(同時出現,20,'同時出現');
如果後面能跟寫趨勢線數值最好,什麼意思,這個指標會出現趨勢線數字的啊

⑶ 股票指標源代碼中的「VB」是指什麼

你這是因為代碼不全,把下面的代碼,粘貼到你公式前面,
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5); V4:=2*(V2-V3)*5.5;
主力撤: IF(V4<=0,V4,0),colorblue;
主力進: IF(V4>=0,V4,0),colorff00ff;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
再試一下,可以關注我,有問題再聯系我。

⑷ 用VB如何直接獲取股票實時數據

可以通過調用ChinaStockWebService的服務來實現獲取股票的實時數據,代碼如下:

publicstring[]getStockInfo(stringstockcode)
{

//stringurl="http://hq.sinajs.cn/list="+stockcode;
//stockcode某隻股票的代碼
stringurl="http://hq.sinajs.cn/list=sh600683";
WebClientclient=newWebClient();
client.Headers.Add("Content-Type","text/html;charset=gb2312");
Streamdata=client.OpenRead(url);
StreamReaderreader=newStreamReader(data,Encoding.GetEncoding("gb2312"));
strings=reader.ReadToEnd();
reader.Close();
data.Close();
returns.Split(',');
}

⑸ 用VB計算器計算股票的高低點

你把每一列的演算法列出來,用EXCEL就能完成了,簡單的公式就行,不必動VB

⑹ 在VB.NET中如何使用新浪股票數據介面

基本沒有,你得和人家有合作關系

⑺ 編寫股票分析軟體需要學會哪些計算機語言

編寫股票分析軟體需要學會的計算機語言是C++、Java、Java Script 、 VB 、Visual Foxpro 語言。
股票分析軟體准確稱為是證券決策分析系統,它是在普通行情軟體的基本功能整加了一些特定的功能,如一些分析大盤的指標、公式,新聞資訊,預警系統,選股系統,盤後分析,信息實時發布系統,研究報告,贏富數據等。" 股市有風險,投資需謹慎",廣大股民朋友要根據自己的需求選擇合適自己的股票軟體,而後結合一定的分析理論和自己的炒股經驗,形成一套自己的、行之有效炒股模式。股票分析軟體實質是通過對股市行情數據的統計,按照一定的分析模型和交易模型匯總成一系列的報表,指標圖形,實時資訊,讓廣大股民朋友更加清晰直觀的從基本面、技術面分析大盤和個股,即時方便的掌握股市的動向。股票分析軟體是炒股的工具,所以請廣大股民朋友要靈活運用。

⑻ 哪位哥們用VB開發過股票軟體

採用vb中的瀏覽器控制項。然後自己弄個空間弄個網站,然後弄個空白頁,插入股票的代碼,然後在用瀏覽器控制項鏈接到上面就可以了。

⑼ 求股票主圖指標 布林線和箱體疊加的指標公式

【箱頂】:PEAK(CLOSE,N1,1)*0.98,LINETHICK2;
【箱底】:TROUGH(CLOSE,N1,1)*1.02.LINETHICK2;
【箱高】:100*(【箱頂】-【箱底】)/【箱底】,NODRAW;

BOLL:MA(CLOSE,N2),POINTDOT,LINETHICK5;
UPPER:BOLL+2*STD(CLOSE,N2),LINETHICK1;
LOWER:BOLL-2*STD(CLOSE,N2),LINETHICK1;

箱體的參數:N1;
布林線參數:N2;
線性、線寬和顏色你自己調吧

⑽ VB 修改一個股票行情監測腳本 到了預定的股價就啟動程序a.exe

Dim file1, file2 As String
Private Sub Command1_Click()

If Val(Text1.Text) > Val(Text2.Text) Then Shell (file1)
'text2.text為大於這個值時 執行
If Val(Text1.Text) < Val(Text3.Text) Then Shell (file2)
'text3.text為小於這個值時 執行
End Sub

Private Sub Command2_Click()
WebBrowser1.Navigate "http://.hexun.com/stock/q.php?code=" & Text4.Text
End Sub

Private Sub Command3_Click()
CommonDialog1.DialogTitle = "選擇路徑"
CommonDialog1.ShowOpen
file1 = CommonDialog1.FileName
End Sub
Private Sub Command4_Click()
CommonDialog1.DialogTitle = "選擇路徑"
CommonDialog1.ShowOpen
file2 = CommonDialog1.FileName
End Sub

Private Sub Form_Load()
Timer1.Interval = 6000
End Sub

Private Sub Timer1_Timer()
WebBrowser1.Refresh
End Sub

Private Sub WebBrowser1_DocumentComplete(ByVal pDisp As Object, URL As Variant)
If Not (pDisp Is WebBrowser1.object) Then Exit Sub
Dim wenben As String
Dim a() As String
wenben = Me.WebBrowser1.Document.Body.innerText
a = Split(wenben, vbCrLf)
Text1.Text = wenben
For i = 0 To UBound(a)
If InStr(a(i), "代碼:") > 0 And InStr(a(i), ".s") > 0 Then
Text1.Text = Right(a(i), (Len(a(i)) - InStr(a(i), ".s")) - 2)
Text5.Text = Mid(a(i), InStr(a(i), ".s") + 1, 2)
Exit For
End If
Next i
End Sub

閱讀全文

與vb編寫股票指標相關的資料

熱點內容
中國第一代海的股票 瀏覽:641
2018可投資股票 瀏覽:156
品牌資產對股票價格的影響 瀏覽:848
查詢股票業績的app 瀏覽:753
回力股票走勢圖 瀏覽:674
st股票為什麼容易漲停 瀏覽:911
公益電影對股票有沒有影響 瀏覽:110
財來股票軟體 瀏覽:301
博雲新材股票會走勢預測 瀏覽:739
影響海南航空股票 瀏覽:621
股票開通港股通的條件 瀏覽:408
股票五指山走勢 瀏覽:516
創業板最低價股票代碼 瀏覽:793
如何查股票交易資金賬戶 瀏覽:744
從合科技股票行情 瀏覽:281
股票幾秒鍾漲停板 瀏覽:792
中國股票倒閉多嗎 瀏覽:628
北方稀土股票現在適合長期持有 瀏覽:901
st是什麼意思股票視頻 瀏覽:429
股票賬戶可以買創業板 瀏覽:810